p0116 etter skifte av kjølevæsketempsensor?

Her poster du alt elektrisk som ikke har med motorstyring å gjøre.

Moderator: Moderatorer

Svar
Brukeravatar
TiaZzz
STCN Styret
STCN Styret
Innlegg: 1576
Registrert: 18 mai 2012, 21:43
Medlemsnummer: N2392
Navn: Mathias Meisfjordskar
Bil: MY02 9-5
Sted: Skjetten, Skedsmo, Akershus

p0116 etter skifte av kjølevæsketempsensor?

Legg inn av TiaZzz » 29 des 2018, 14:06

Hepp.

Udde problem på niofemma'n nå i romjula. Har lagt merke til at tempnåla har vært litt humørsyk i det siste, men siden vifta har gått som normalt og kupéen blir varm så har jeg skrevet det ned som tempsensor som er moden for utskifting.

På en tur her så gikk nåla i dørken og CE-lampa kom opp. Jeg har selvfølgelig reist fra alt av OBD2-lesere så jeg stakk innom en Mekonomen og kjøpte en ny sensor som jeg byttet ute på gårdsplassen. Nappet strøm av for å slette feilkoder og trodde alt var i orden. Nå viser det seg at CE ikke var borte og måleren fortsatt er litt humørsjuk. Handla meg leser på 'tema og fikk lest ut p0116 - som er typisk denne sensoren. Sletta koden og ikke fått den igjen på tur fra Arendal til Grimstad.

Nå tror jeg at det kan være en av to feil:
  1. Gåen sensor og termostat. Nå er den ene fikset så tempsigninger er resultat av dårlig termostat.
  2. Dårlig kontakt til sensoren. Det er jo strømpe på alt av ledninger her så jeg ser ingenting
Er det noen typiske punkter i ledningsnettet som er utsatt? Så fra et engelsk forum at ved J17 så kunne det bli brudd. Ikke sikker hvor det er.

Fant forøvrig en dårlig jallamekk på veivhusventilasjonen som måtte fikses i samme slengen, men ser ikke helt at det har noen sammenheng.

Brukeravatar
Kato
2.0 bar
2.0 bar
Innlegg: 816
Registrert: 05 nov 2013, 23:08
Navn: Kato Herland
Bil: Saab 9-3 SC Aero 2.0T XWD
Sted: Tromsø

Re: p0116 etter skifte av kjølevæsketempsensor?

Legg inn av Kato » 30 des 2018, 14:02

J17 er jord (fra ECM) til sensoren samt andre "abonnenter", slike som veivakselgiver, spjeldhus etc. så at problemet ligger der er vel mindre sannsynlig, med mindre det er vakkel i ledningen sensor/J17.

En mer sannsynlig kandidat er kanslje termostaten, slik du er inne på. i WIS feilleitingsproserdyre ifm. P0116 er de første stegene kontroll av kjølevæskemengde, frostpunkt og at termostaten fungerer som den skal. Om dette er i orden starter stegene med kontroll av sensoren med tilledninger.

Ved et søk på STCS kan det se ut som tilsvarende tilfeller med det du erfarer avhjelpes med skifte av (bare) termostaten.

OG: det synes svært viktig at skifte av termostat må være av OEM type.
2009 Saab 9-3 SC Aero 2.0T XWD/eLSD Aut., eSID2.

Brukeravatar
TiaZzz
STCN Styret
STCN Styret
Innlegg: 1576
Registrert: 18 mai 2012, 21:43
Medlemsnummer: N2392
Navn: Mathias Meisfjordskar
Bil: MY02 9-5
Sted: Skjetten, Skedsmo, Akershus

Re: p0116 etter skifte av kjølevæsketempsensor?

Legg inn av TiaZzz » 04 jan 2019, 17:59

Ser ut som en kombinasjon av sensor, termostat og/eller væske var synderen for etter bytte av alle tre så oppførte bilen seg på testturen i går kveld.

Handla original termostat hos Motorforum Kjeller. Orker ikke flere uoriginale etter noen feilkjøp. 170+mva eller noe sånt så det er ikke rare summene.

Feilkoden skal kun komme av gåen sensor så den eller ledningen var gåen. Da jeg fikk CE så gikk måleren fra kl. 8 ca. og rett i dørken, noe som ikke kan være reelt.

Brukeravatar
Hjelle, N6
Site Admin
Site Admin
Innlegg: 8139
Registrert: 25 feb 2003, 01:00
Medlemsnummer: N6
Sted: Sunnmøre
Kontakt:

Re: p0116 etter skifte av kjølevæsketempsensor?

Legg inn av Hjelle, N6 » 04 jan 2019, 19:52

Feilkoden vert også sett om givarverdien viser 20 grader under eller 48 grader over referanseverdien som vert kontinuerlig berekna ut frå at innsugslufttempen ved start + 1 grad pr 60g luftmasse pr sekund, dog max 90 grader slik eg forstår det.
So det er fullt mulig å få den feilkoden utan at givaren er gåen slik eg ser det. :)
M91 900 Turbo 16 // M04 9⁵ Aero // M11 9⁵ 2.0T BioPower XWD // SAAB-ANDAN - en del har den

Brukeravatar
TiaZzz
STCN Styret
STCN Styret
Innlegg: 1576
Registrert: 18 mai 2012, 21:43
Medlemsnummer: N2392
Navn: Mathias Meisfjordskar
Bil: MY02 9-5
Sted: Skjetten, Skedsmo, Akershus

Re: p0116 etter skifte av kjølevæsketempsensor?

Legg inn av TiaZzz » 04 jan 2019, 20:13

Inkluderer det at nåla gir opp? Det var grunnen til at jeg tenkte sensor først.

Brukeravatar
Hjelle, N6
Site Admin
Site Admin
Innlegg: 8139
Registrert: 25 feb 2003, 01:00
Medlemsnummer: N6
Sted: Sunnmøre
Kontakt:

Re: p0116 etter skifte av kjølevæsketempsensor?

Legg inn av Hjelle, N6 » 05 jan 2019, 10:42

TiaZzz skrev:
04 jan 2019, 20:13
Inkluderer det at nåla gir opp? Det var grunnen til at jeg tenkte sensor først.
Nåla får data frå givaren ja, so det er ikkje unaturleg å tenke. Men slik eg tenker det er det mulig å få feilkoden og at det kun er termostaten som er gåen. Dette på grunn av at om termostaten fks heng seg i åpen eller lukka stilling vil givaren vise korrekt verdi iforhold til vasstemp, men feilkoda vil verte trigga iforhold til nemnte referanseverdi om eg har forstått dette rett. Men givaren kan jo gi heilt galne verdiar og termostaten fungere, og tverrt om...
M91 900 Turbo 16 // M04 9⁵ Aero // M11 9⁵ 2.0T BioPower XWD // SAAB-ANDAN - en del har den

Svar