"Rattlåsfel" i SID og problemer med start

Her poster du alt elektrisk som ikke har med motorstyring å gjøre.

Moderator: Moderatorer

Svar
Brukeravatar
summilux
Innlegg: 10
Registrert: 23 jul 2013, 21:15
Bil: 9-3 1.8t manuell, 2004
Sted: Trondheim

"Rattlåsfel" i SID og problemer med start

Legg inn av summilux » 25 jan 2019, 15:54

Jeg har prøvd å søke litt her på forumet omkring det jeg beskriver her, uten å bli helt klok, så jeg velger å lage en tråd på det.

Jeg har en 2004 9-3 som har fungert feilfritt inntil rett før jul. Da fikk jeg beskjed på SID displayet om "Rattlåsfel, stanna snarast och kontakta verksted" (fritt etter hukommelsen). Første gang parkerte jeg i garage og lot den stå til dagen etter, startet uten problemer og fungerte i et par dager til meldingen kom igjen. Prøvde da å låse bilen når jeg satt inni, banket med nøkkelen på tenningslåsen, deretter responderte den på tenningen og bilen startet igjen. i Det siste har også blinklysene sluttet å fungere etter en slik feilmelding, ved stans og start på nytt fungerer dem. Dette har kommet og godt de siste to månedene, jeg har googlet litt i forsøk på å finne ut hva som er feil og/eller må byttes. Kan også legge til at den karakteristiske "klikk" lyden når jeg setter inn/tar ut nøkkelen er borte når jeg får feilmeldingen.

I tillegg har jeg problemer med blinklyset på høyre side, det blinker veldig fort som om en pære er gått, men så fungerer det normalt igjen. Ved hurtig blinking blinker ikke det lille lyset på skjermen ved siden av døren, når alt fungerer som det skal blinker også dette lyset.

Siden jeg ikke er hverken bilmekaniker eller elektriker, tenkte jeg det var lurt å høre litt med dere som med stor sannsynlighet har litt mer peiling og forhåpentligvis råd. Jeg har sett at det er mulig å bytte tenningslås, men vil gjerne høre hva dere tenker, både om det er noe jeg kan gjøre selv/få hjelp til av min kyndige far, eller hva jeg evt. må kjøpe nytt.

Jeg leser ting som kan hjelpe; kjøpe nytt bilbatteri, sjekke batteriet i selve nøkkelen (jeg har to), bytte rattlåsen. Men hva og hvor starter jeg?

Håper noen har erfaringer med dette og kan gi meg noen svar.

Brukeravatar
Saabfan
2.0 bar
2.0 bar
Innlegg: 928
Registrert: 17 feb 2005, 01:00
Medlemsnummer: N1227
Bil: Saab 9-5 AERO Estate
Sted: Oslo

Re: "Rattlåsfel" i SID og problemer med start

Legg inn av Saabfan » 25 jan 2019, 19:03

Hei,

Det var flere ting på en gang du snakker om her - og det er meget mulig det henger sammen. Ang. tenningslåsen og feil rundt dette er det vel typisk to moduler som kan feile; CIM i rattstammen (rattlåsen) og ISM (tenningslåsen). Disse snakker sammen og feil på disse gir gjerne problemer med rattlås og immobilizer.

Det som uansett er gratis å prøve er å rense ISMen. Det kan kanskje hjelpe - og hjelper ikke det så har du hvertfall eliminert det som feilkilde.

Du gjør det slik;

https://www.youtube.com/watch?reload=9&v=eYmzXdLuPms
https://es.ifixit.com/Gu%C3%ADa/Saab+9- ... 01?lang=en

Så lenge du ikke er født med ti tommeltotter så går det rimelig raskt og greit. :D
9-5 2.0t VECTOR ESTATE MY02 -> NÅ FULLBLODS AERO!
9-3 1.8t VECTOR CABRIOLET MY05

9000CS M95 - solgt
900 M93 2.1L 16 valve - solgt
900c M87 - på de evige autobaner

Brukeravatar
Kato
2.0 bar
2.0 bar
Innlegg: 870
Registrert: 05 nov 2013, 23:08
Navn: Kato Herland
Bil: Saab 9-3 SC Aero 2.0T XWD
Sted: Tromsø

Re: "Rattlåsfel" i SID og problemer med start

Legg inn av Kato » 25 jan 2019, 21:38

summilux skrev:
25 jan 2019, 15:54
- Jeg leser ting som kan hjelpe; kjøpe nytt bilbatteri, -
Jeg ville nok ha startet med å måle batterispenning, da dette er enkelt og «NG9-3» er følsom for lav slik. Spenningen bør ligge over 12,3-12,4V med tenningsnøkkelen i posisjon «ON», og ikke under 9,6V når startmotoren går.

Ladespenning skal være 14,4-13,8V.
2009 Saab 9-3 SC Aero 2.0T XWD/eLSD Aut., eSID2.

Brukeravatar
summilux
Innlegg: 10
Registrert: 23 jul 2013, 21:15
Bil: 9-3 1.8t manuell, 2004
Sted: Trondheim

Re: "Rattlåsfel" i SID og problemer med start

Legg inn av summilux » 26 jan 2019, 09:03

Saabfan skrev:
25 jan 2019, 19:03
Så lenge du ikke er født med ti tommeltotter så går det rimelig raskt og greit. :D
Jeg har vel sånn cirka seks tommeltotter, men med slike tips og veiledninger skal selv jeg klare det. :D
Kato skrev:
25 jan 2019, 21:38
Jeg ville nok ha startet med å måle batterispenning, da dette er enkelt og «NG9-3» er følsom for lav slik.
Jeg har lagt merke til at hun ikke er like fyrrig nå på vinteren med kuldegrader som tidligere i høst, så nok et godt og konkret tips. Eliminering er et godt utgangspunkt, jeg er rimelig god på diagnostisk forståelse av menneske, ikke like dreven på bil/elektronikk. Okke som, jeg får kjøpe mitt første multimeter i dag og se hva jeg finner ut av. Takk begge to for tips og råd så langt, regner med jeg kommer med tilbakemeldinger her.

Brukeravatar
summilux
Innlegg: 10
Registrert: 23 jul 2013, 21:15
Bil: 9-3 1.8t manuell, 2004
Sted: Trondheim

Re: "Rattlåsfel" i SID og problemer med start

Legg inn av summilux » 27 jan 2019, 16:36

Kjapp tilbakemelding etter målinger i dag.
Målt uten at tenningen er på viser den 12,14V. Med tenningen på ON 11,78V og når jeg starter den faller den ned til 9,6 (om jeg ikke husker feil). Så antar jeg at ladespenning er det samme som når motoren er i gang? Den viser i alle fall 14.80V da.

Er dette såpass lavt/variasjon i spenningen som du anbefaler Kato, at jeg bør kjøpe et nytt batteri og se om det gjør noe til eller fra?

Brukeravatar
Kato
2.0 bar
2.0 bar
Innlegg: 870
Registrert: 05 nov 2013, 23:08
Navn: Kato Herland
Bil: Saab 9-3 SC Aero 2.0T XWD
Sted: Tromsø

Re: "Rattlåsfel" i SID og problemer med start

Legg inn av Kato » 27 jan 2019, 20:29

I kortform viser målingene at dette er et batteri som enten er utladet og/eller sterkt redusert. 12,14V indikerer at det nå har <40% kapasitet. Vet du hvor gammelt det er?

Så kan man filosofere litt over målingene: 14,80V ladespenning er noe jeg ikke har sett nevnt tidligere, men kan ha som årsak toleransen til multimeteret eller det at ladespenningen er høyere for et batteri "som må ha påfyll" enn når det er oppladet, ref. tidligere nevnte område for ladespenning.

Jeg vet jo ikke hva toleransen på dette meteret er (?), men om en tenker seg at den er +2,5% ville det kunne forklare den høye ladespenningen. I så tilfelle ville dette gjøre at de andre målte spenningene også var for høye - og befeste kortform konklusjon mht. batteriets status.

OM dette nå er modent for utskifting eller kun trenger en god porsjon vedlikeholdslading, er vel noe du selv best kan avgjøre, da du kjenner til bruk, lading/utlading og alder på dette. Fra mitt ståsted, uten slik kjennskap, heller jeg nok til at batteriet kunne trenge ein avløysar.

Dette med vedlikeholdslading av batteri er vel ikke et tema her, men slik lading KAN lønne seg med tanke på pris på tilgjengelige ladere og at man kanskje kan fordoble levetiden på batteriet.
2009 Saab 9-3 SC Aero 2.0T XWD/eLSD Aut., eSID2.

Brukeravatar
summilux
Innlegg: 10
Registrert: 23 jul 2013, 21:15
Bil: 9-3 1.8t manuell, 2004
Sted: Trondheim

Re: "Rattlåsfel" i SID og problemer med start

Legg inn av summilux » 27 jan 2019, 22:30

Takk for raskt svar, skal prøve å utdype litt mer her.
Batteriet er kjøpt på Biltema for cirka tre år siden om jeg ikke husker feil, ikke av de billigste utgavene og amper husker jeg ikke i farten. Det er for det neste småkjøring til og fra jobb, 10-15 minutters bykjøring i Trondheim og ganske lite lengre/langkjøring.

Meteret ble kjøpt på Jula i går av typen Uni-T, bildet vedlagt under her. Målte på 20V.
Bilde

Her er målingene, det første uten tenningen på.
Bilde

Her med tenningen i ON posisjon
Bilde

Motoren i gang
Bilde

Jeg vet dessverre for lite om dette til at jeg kan gi deg mer presise svar. En batterilader koster ikke all verden og er tenkt innkjøpt, men jeg vet ikke om jeg skal prøve å la det lade opp over et par-tre dager og se om det gir bedring, eller om jeg bare skal få tak i et nytt batteri? Det siste virker mest logisk med tanke på problemstillingen her, så har jeg batteriladeren til vedlikeholdslading.

Brukeravatar
Kato
2.0 bar
2.0 bar
Innlegg: 870
Registrert: 05 nov 2013, 23:08
Navn: Kato Herland
Bil: Saab 9-3 SC Aero 2.0T XWD
Sted: Tromsø

Re: "Rattlåsfel" i SID og problemer med start

Legg inn av Kato » 28 jan 2019, 11:06

Om du likevel går for å begynne med vedlikeholdslading vil jeg tro et nytt batteri først kan være veien å gå.

Vedlikeholdslading av det eksisterende vil, som du er inne på, måtte ta tid; >25 timer sammenhengende lading (eller mer i tilfelle bilen brukes under denne tiden) for om mulig få et svar på tilstanden.

I en blyakkumulator vil prosessen «sulfatering» starte ved en spenning <12,45-12,55V, og er irreversibel. Dette fører til at batteriet gradvis mister evnen til å ta (full) lading, og har dette pågått i tre år som kanskje i ditt tilfelle, styrker det tanken om det er (sterkt) svekket.

(Rest-)kapasiteten til et batteri kan forøvrig testes på riktig måte av et (NAF-)verksted, eller tilsvarende.
2009 Saab 9-3 SC Aero 2.0T XWD/eLSD Aut., eSID2.

Brukeravatar
summilux
Innlegg: 10
Registrert: 23 jul 2013, 21:15
Bil: 9-3 1.8t manuell, 2004
Sted: Trondheim

Re: "Rattlåsfel" i SID og problemer med start

Legg inn av summilux » 28 jan 2019, 11:45

Da går jeg for et nytt batteri tenker jeg, så ser jeg om det gjør noe til eller fra med tanke på feilmeldingen og funksjonssvikten på bl.a blinklys.

Takk for verdifull tilbakemelding, det er nyttig og god lærdom for meg dette som jeg også tar med videre.
Skal også plukket ned og renset ISM når jeg får anledning, kommer nok tilbake her når jeg har litt oppdateringer å dele.

Svar